I'm at my wits end

turbo chris1970

Engine bay
Ok this spring my car was in the garage for about 1 year and a half so far I changed the battery , alternator, belt, plugs , changed the fuel filter, checked everything for a nice simple inspection so she fired up and idled fine so I went for a test drive and and backing out of my driveway I noticed it was idling low then in gear OD I pulled down the street and she starts popping like a popcorn machine my AF was all over the place starving for gas I gave it gas then running rich and more popping yet no codes were thrown at me no knock !!!! So guys is it time for new wires and a good tune I've been putting 93 Sunoco and injector cleaner in it and it seems my gas mileage is like 5 to the gallon and I have a new pump and sender unit and a year old set of 60lb injectors so guys any advice or had similar problems?
 

SHADOWII

Well-Known Member
Do you have a way if checking the fuel pressure,(gauge on the fuel rail) ignition module/coil pack? Check for a loose crank sensor. Cam sensor set properly? Good maf? No air leaks in hose between maf and turbo?
You can easily check your wiring and coil pack for leakage at night by starting up the car and opening up the hood. If there is a leak in the wiring or coil pack, it becomes very visible in the dark. Rev the engine if necessary.
 

pmesfun

Active Member
Bad ground, ecm, the right chip for your injectors? You have a scanmaster.

Sent from my SAMSUNG-SM-G920A using Tapatalk
 

Nick Micale

Tech Advisor
Staff member
Ok this spring my car was in the garage for about 1 year and a half .....................
If the gas is a year and a half old it should have been drained and used for killing weeds.

Good chance the injectors are only partially flowing and popping starts when going lean with RPM?
 

MAK507

Active Member
Weird. I posted last night about 20 minutes after OP made the post.. and it's gone.

original post:

I hate to be the one to ask, but seeing as you had the car sitting for a year and a half, did you remove the old gas and fill her back up with fresh gas before running her down the street? this could be the problem!
 

turbo chris1970

Engine bay
Any update??


Sent from my iPhone using Tapatalk[/QUOTE
Here is an update guys thanks for the support we gotta keep these cars on the road so I had time the past few days to go over everything again so here is my combo 4000miles on a set of 60lb Delphi s translator ver.6.2 with my maf from a impala ss 3"down
New k&n no leaks a soon to be gone turbonetics 62mm and a new fuel filter a under 4000 mile 340 walbro
The filter was 10 lbs when I changed that biotch but errrr didn't take old gas out to kill my lawn so I changed the alternator belt plugs but didn't change my wires msd's should have
Fuel presure gauge was at 42 psi one good thing we all hate is passenger side last plug changed it out in a record in and out in3 min flat
Buts it's frigging July and I drove the car to the supermarket but here's the
Deal I don't currently have a scan master cause I'm trading up to the gauge on my a pillar and taking my boost gauge out so I have knock and a wideband a/f so no codes on my trip and drove in D and no popcorn
A/f a little lean and good during a test of boost so I checked my relays for the fuel pump and god damm dirtier than a hooker on crack melted so slid them out and busted out WD and got to it cleaned crud out luckily no wire damage but ran out of daylight so I had to just lock it up and even checked my ECU for connections everything is good oh forgot Erick Marshall custom burned my chip for the combo so that's squared away
But damm guys and gals I checked everything on that car I admit I learned I shoulda, coulda, and woulda done things different and will when the season is over trial and error but my car is a fully loaded gray turbo t lastly no problems with my stage 2 200r4 so that's what's up what do you guys and gals think? And please be gentle the seasons half way over then back in the garage she goes before the winter gas comes to destroy our cars
 

nat86

Active Member
Does your alternator light come on before you start the car

Sent from my SM-N910T using Tapatalk
 

turbo chris1970

Engine bay
Does your alternator light come on before you start the car

Sent from my SM-N910T using Tapatalk
No everything is normal my RPMs are too low when I'm at a light stopped and it's starving for fuel
Does your alternator light come on before you start the car

Sent from my SM-N910T using Tapatalk
the check engine brake and
No everything is normal my RPMs are too low when I'm at a light stopped and it's starving for fuel
Everything is NOT normal if the lite does not come on B4 you start the car.
My check engine light comes on then goes off and brake light goes on and off and left side lights I think it's oil choke then goes off and I've been up since 4am and can't think of the light below it damm
 

turbo chris1970

Engine bay
Does your alternator light come on before you start the car

Sent from my SM-N910T using Tapatalk
No everything is normal my RPMs are too low when I'm at a light stopped and it's starving for fuel
Does your alternator light come on before you start the car

Sent from my SM-N910T using Tapatalk
the check engine brake and
No everything is normal my RPMs are too low when I'm at a light stopped and it's starving for fuel
Everything is NOT normal if the lite does not come on B4 you start the car.
My check engine light comes on then goes off and brake light goes on and off and left side lights I think it's oil choke then goes off and I've been up since 4am and can't think of the light below it damm
 

turbo chris1970

Engine bay
Does your alternator light come on before you start the car

Sent from my SM-N910T using Tapatalk
No everything is normal my RPMs are too low when I'm at a light stopped and it's starving for fuel
Does your alternator light come on before you start the car

Sent from my SM-N910T using Tapatalk
the check engine brake and
No everything is normal my RPMs are too low when I'm at a light stopped and it's starving for fuel
Everything is NOT normal if the lite does not come on B4 you start the car.
My check engine light comes on then goes off and brake light goes on and off and left side lights I think it's oil choke then goes off and I've been up since 4am and can't think of the light below it damm
 
Top