No brake lights

turbo chris1970

Engine bay
Well took the T to the post office and a guy pulled Along side of me to inform me that my lights were on but my 3rd brake light was on but my tail lights were not I converted to vacuum brakes 2 years ago and I heard a RUMOR that it has something to do with a white white can someone help me out thanks
Chris
 

No disintegrations

Well-Known Member
More likely the turn signal switch since SIG's have to turn on and off while braking and turn signal is on
The high mount does not have this problem.
 

turbo chris1970

Engine bay
More likely the turn signal switch since SIG's have to turn on and off while braking and turn signal is on
The high mount does not have this problem.
Do you mean the fuse? Or a wire under the dash
More likely the turn signal switch since SIG's have to turn on and off while braking and turn signal is on
The high mount does not have this problem.
Well took the T to the post office and a guy pulled Along side of me to inform me that my lights were on but my 3rd brake light was on but my tail lights were not I converted to vacuum brakes 2 years ago and I heard a RUMOR that it has something to do with a white white can someone help me out thanks
Chris
More likely the turn signal switch since SIG's have to turn on and off while braking and turn signal is on
The high mount does not have this problem.

More likely the turn signal switch since SIG's have to turn on and off while braking and turn signal is on
The high mount does not have this problem.
ok so should I look for a fuse or or the wire that is in the turn signal switch and adress the problem in the switch where the white who're is near the cruise control switch your help is greatly appreciated buddy Chris
 

No disintegrations

Well-Known Member
My first instinct is something unplugged or wrong with turn signal switch since you were under there:D. But also because of the symptom you give. ( The center brake light works, left and right don't. ) Cars with red rear turn signals have brake light wiring which makes its way through the turn signal switch. The center light can be lit at all times the brakes are pressed. That is because when you brake and turn signal at the same time the light needs to be interrupted to flash. Make sense?

Cars with orange rear turn signals don't have this wiring tied into the brake lights.

But yes always check fuses too.
 

turbo chris1970

Engine bay
I've been under the car all afternoon and am taking apart the steering column right under the shaft to look for anything loose or broken I am a stubborn dude
 

No disintegrations

Well-Known Member
Stubborn is good when trying to find problems! Maybe a bit late on this but it's possible you have a bunch of burned out bulbs back there. You check them yet? Check they get power and ground?
 

turbo chris1970

Engine bay
Stubborn is good when trying to find problems! Maybe a bit late on this but it's possible you have a bunch of burned out bulbs back there. You check them yet? Check they get power and ground?
I replaced all bulbs over the winter while in ribernation in the garage but will double thanks , ChrisChris
 

Toecutter

New Member
By my experience, look at the connector that connects the steering column wiring to the factory harness. The factory made these areas very tight so the wires are under tension. The white wire is the brake signal wire. You will have to run a jumper from one side to the other side. What happens is the wire is so tight that the little connector inside gets pulled back and fails to make contact with the other side. Common occurrence in G Body cars.
 

turbo chris1970

Engine bay
By my experience, look at the connector that connects the steering column wiring to the factory harness. The factory made these areas very tight so the wires are under tension. The white wire is the brake signal wire. You will have to run a jumper from one side to the other side. What happens is the wire is so tight that the little connector inside gets pulled back and fails to make contact with the other side. Common occurrence in G Body cars.
I followed your advice and everything
Is working thanks for the advice,Chris
 
Top