Power Logger Review Help Needed - KR!

Long story short....
New stroker motor installed.
Runs great but has some KR. I'm thinking/hoping false KR but cannot find the source. TT 5.7 chip, all settings at base. FP line off is 43. ALky primed. HR motor mounts, both sides. DP and all exhaust is clear. Cannot find anything loose anywhere. Removed and reinstalled knock sensor to see that it wasn't in too tight. The attached file was running with waste gate actuator disconnected. Turbo spools so fast, I had to disconnect to keep it in check. I know KR is small but with the actuator on it would spike higher so fast I had a hard time reacting. What does anyone see/think?

1585603522091.png
 

Attachments

  • 3.30.20.dat
    162.5 KB · Views: 80
I wasn't logging but do have a temporary gage on my windshield and it looked good. Having said that , things happen so fast I cannot be sure.
Not sure how to log FP with powerlogger but do have an xfi system I was planning to install but wanted to get it running right before I made another big change; eliminating variables...
maybe I should just install a new fuel pump, I don't fully know the history of the one I have.


Sent from my iPhone using Tapatalk
 

87GN864

Member
I would say that you're seeing false knock. With only 11 pounds of boost and your o2 reading being on the richer side, I can't see that being anything to worry about. Getting out of it as soon as you see the knock is the best thing to do, but I would bet if you stayed in it the knock would have disappeared right away. It could be anything picking up that little bit of noise.
 

SCOOBY DOO

I'M NOT A MONSTER, I'M JUST AHEAD OF THE CURVE!!!
Frame 1188 shows you slightly getting out of it...and getting back into it at 1192 via TPS. If you line up KR and Engine Speed you'll note the KR starts at 4311 RPM...and then fades off...which leads me to think the knock sensor heard something and the KR isn't real. 02's and BLM's appear to be fine. You're in doubt of the fuel pump...so change it. Cheap insurance against head gaskets.
 
I would say that you're seeing false knock. With only 11 pounds of boost and your o2 reading being on the richer side, I can't see that being anything to worry about. Getting out of it as soon as you see the knock is the best thing to do, but I would bet if you stayed in it the knock would have disappeared right away. It could be anything picking up that little bit of noise.
I hear you and hope you are right. However, I have another log showing a spike to 10+ at 21 psi (before disconnecting the WG actuator) and that really scares me too much to try and drive past it.
 
Frame 1188 shows you slightly getting out of it...and getting back into it at 1192 via TPS. If you line up KR and Engine Speed you'll note the KR starts at 4311 RPM...and then fades off...which leads me to think the knock sensor heard something and the KR isn't real. 02's and BLM's appear to be fine. You're in doubt of the fuel pump...so change it. Cheap insurance against head gaskets.
Thanks for the analysis and I hope you are right! It sure doesn't make me feel good to look over at the scanmaster and see those numbers
 

SCOOBY DOO

I'M NOT A MONSTER, I'M JUST AHEAD OF THE CURVE!!!
I hear you and hope you are right. However, I have another log showing a spike to 10+ at 21 psi (before disconnecting the WG actuator) and that really scares me too much to try and drive past it.
Can you post that log?
 

SCOOBY DOO

I'M NOT A MONSTER, I'M JUST AHEAD OF THE CURVE!!!
The file you just posted...the KR is real. 02's dropped off to 756. You've got a fueling issue. I'd guess the fuel pump, alky pump or both. Install a new Denso 02 sensor as well. The ECM does its fueling from what the 02 sensor sends it.
 

SCOOBY DOO

I'M NOT A MONSTER, I'M JUST AHEAD OF THE CURVE!!!
Did you go to a bigger turbo? If so the chip won't have enuf fuel in it.
 
Thanks again Scooby Doo! Same turbo; it's a TE44. Alky pump is only a year old so I'm expecting it is OK. I ran 25 psi before and didn't seem to have a fuel issue. Now I'm thinking I should go ahead with the XFI install since that will inc a wideband and fuel pressure logging. I may try adding fuel with the chip first though.
 

SCOOBY DOO

I'M NOT A MONSTER, I'M JUST AHEAD OF THE CURVE!!!
Scooby - With that KR for only 1 second or so; I wouldn't have hurt anything, right? :)
It takes very little to pop a head gasket or pound connecting rod bearings into tin foil...unfortunately. You got out of it quick...so hopefully everything is still intact. I think you'll be fine. You HAVE to be on top of the fueling systems like a hawk.
 
Top