No WOT upahifts.

#1
87GN. Did a manual downshift to 2nd, hammered throttle, after which it will no longer do wot shifting. Will be in 3/4 by 40-45 mph.
TV cable has spring tension, new TCC, governor and springs in place, solonoid fuse okay, new fluid and filter, all wiring properly hooked up, TV cable yanked several times and properly adjusted. Other than no wot upahifts the trans works aokay. I dread having to drop the vb but looks like that's where I m at!! Any other suggestions before the dreaded vb drop will be much appreciated.
Thanks
 

Lil Truck

I spend to much time here....
#6
From a stop in D, it will shift thru the gears and be in 4th by 40-45 mph.
From a stop in D, it will shift thru the gears and be in 4th by 40-45 mph.
If it was mine I would drop the valve body clean and inspect all the valves, clean the separator plate, New plate gaskets. Inspect the governor weights for free operation and replace the seal. Check clean and inspect the servo and it wouldn't hurt to inspect the accumulator.
 
#8
If it was mine I would drop the valve body clean and inspect all the valves, clean the separator plate, New plate gaskets. Inspect the governor weights for free operation and replace the seal. Check clean and inspect the servo and it wouldn't hurt to inspect the accumulator.
Yes, I think I'm at that point.
 
#9
Finally got around to dropping the valve body and did not find anything out of order, seized, broke, or missing. The governor is as supposed to be. I have not re-installed the valve body in hopes that some other suggestions might be made before I bolt it back in.
One note...the T.V modulator upshift spring was not in place but I've read in both the ATSG manual and in Chris Kokkonis manual that some models of the 2004R does NOT have the spring??

Still open for suggestions.

Thanks for all your help, I do appreciate.

Jerry
 

Lil Truck

I spend to much time here....
#10
You are correct about the MTV upshift , no spring in BED vb. How did the small spring on the end of the TV look?
Something is keeping the line pressure from increasing as far as I can determine. I am not a trans tech, just learning. Next would be pump and converter......just my opinion.
 

Lil Truck

I spend to much time here....
#12
You are correct about the MTV upshift , no spring in BED vb. How did the small spring on the end of the TV look?
Something is keeping the line pressure from increasing as far as I can determine. I am not a trans tech, just learning. Next would be pump and converter......just my opinion.
(BRF). Spell check got me.
 

TexasT

Texas, Where are you from
#13
Did you pull the boost valves out of the pump while apart? could be stuck. If you decide to go deeper pulling the pump and disassembling could reveal something but that is more work.

When you get it back together you need a pressure gauge on there and see what the thing is doing.