No oil pressure

sheadiggity

New Member
The whole story….
My first eyebrow raised was left car running in Park for about 10 minutes noticed sound to me like valve taps! But when drove and gave gas noise went away. That was about three weeks ago two weeks ago I was cruising on a double lane road at night and I seen a hellcat in my rearview mirror flying toward me from a distance I waited till he got a little closer before I stepped into the throttle and was neck and neck with him then I seen smoke inside the car so I let off I thought it was on fire I am mediately pulled over and checked and oil was everywhere on the driver side, checked oil and was way over full Half way up to stick but very clean, so I changed oil and filter and have not had any problems for about a week of daily driving , last Friday after running some errands I zipped it up the hill and all of a sudden was a loss of power almost like a miss and zero oil pressure. Luckily I was only a couple hundred yards from home and babied it there! I always have used VR one Race oil and AC Delco larger filter, Any advice on what to diagnose?
 

Turbo6inKY

Short Guy
The oil was likely coming out of the dipstick tube.
You probably have a blown head gasket. When you get on it, it pressurizes the crankcase and oil spits out of the dipstick tube.
The event(s) that blew the gasket probably damaged a bearing, too.

You should not drive the vehicle until you've diagnosed it. A compression check is your next troubleshooting step.
 

sheadiggity

New Member
The oil was likely coming out of the dipstick tube.
You probably have a blown head gasket. When you get on it, it pressurizes the crankcase and oil spits out of the dipstick tube.
The event(s) that blew the gasket probably damaged a bearing, too.

You should not drive the vehicle until you've diagnosed it. A compression check is your next troubleshooting step.
I have a piece of rubber line that fits on the end of the stick near the handle and it seals the dipstick when it’s completely down in I don’t think it came from there, I think it came out of the driver side breather on the valve cover because it was over full of oil but I’m not 100%.. like I said I drove it over a week after that and had no problems! I actually took it on a two hour round-trip under normal driving conditions and got into it a couple times here and there and it never happened again I just thought it was worth mentioning due to the problem now . When I zipped it on Friday it lost power and zero pressure! I always had very decent oil pressure. About 50 to 60 at cold start idol and about 20 at idle when hot between 160 and 180° at about 1200 RPMs and always would go up when accelerating 30 pounds plus then back down to 20 at idle I think how it should be?

The first thing I did was take compression readings because I thought head gasket blew as well. Here is my readings I think that they are good compression
 

Attachments

  • D6C9702C-83C0-4144-9D6D-1CB825E44997.jpeg
    D6C9702C-83C0-4144-9D6D-1CB825E44997.jpeg
    1.7 MB · Views: 27

sheadiggity

New Member
All look great
 

Attachments

  • 22024F47-66DF-4779-8AA2-54F7126AD6C3.jpeg
    22024F47-66DF-4779-8AA2-54F7126AD6C3.jpeg
    1.2 MB · Views: 35
  • F39264C5-D9B2-4A39-94BB-E56F570941B3.jpeg
    F39264C5-D9B2-4A39-94BB-E56F570941B3.jpeg
    1.2 MB · Views: 36

1KWIKSIX

Well-Known Member
Did you check your compression with a warmed up engine & throttle body wide open while briefly cranking ?
Leak down test will tell it all.
 

sheadiggity

New Member
Yes And I did all cylinders have 5-8% leakage no noise out of intake,exhaust,no radiator bubbles,ect.
I’m cutting open oil filter today.
I seen a YouTube video of oil pump gear round off shaft splines . I’m hoping that’s what’s wrong also does classic fast have some kind of fellsafe that protects engine when it gets a low oil pressure signal?
 

TexasT

Texas, Where are you from
Are you logging anything? Electric or mechanical gauge? Have you looked at the pressure with another gauge?
 

RichieRocket

Active Member
Yes And I did all cylinders have 5-8% leakage no noise out of intake,exhaust,no radiator bubbles,ect.
I’m cutting open oil filter today.
I seen a YouTube video of oil pump gear round off shaft splines . I’m hoping that’s what’s wrong also does classic fast have some kind of fellsafe that protects engine when it gets a low oil pressure signal?
Yes, you can set XFI to shut down at certain fuel and oil pressure.
 
Top