MAINTENANCE, CAR HAS BEEN SITTING FOR 10 YEARS

Flipped Auto

New Member
Joined
Dec 14, 2011
I HAVE A 87GRAND NATIONAL, MOSTLY STOCK..HAS BEEN SITTING FOR 10 YEARS OR SO , SO IT IS IN NEED OF MAINTENANCE AND FRESHING UP .... THE CAR DOES START UP AND IDLE ( SO WHAT ROUGH IDLE) STUMBLES ON ACCEL

NEW PARTS SO FAR
*FUEL TANK
*FUEL PUMP
*SPARK PLUGS AND WIRES (COIL AND IGNTION MODULE)
*FUEL FILTER
*MOST FLUIDS
*SCANMASTER G -NO DATA DUE TO FAN RELAY OR TCC RELAY, ORDERED NEW ECM WILL LEAVE THOSE COMPONENTS UNPLUGGED

(((((((PARTS LIST NEEDED)))))
IAC
TPS
PCV
INJECTORS (THINKING MAY NEED REPLACED 15 YEARS OF SITTING)
HOTWIRE FOR FUEL PUMP
WIDE BAND O2

JUST TRYING TO SEE IF IM GOING IN THE RIGHT DIRECTION OR IF ITS STUFF I MAY BE OVERLOOKING
 

joed

Active Member
Joined
Mar 6, 2002
i see you’ve been firing the cannon. I’d hang onto the old ignition coil and module. Aftermarket units known to be hit and miss, unless you got them from one of the vendors on this forum. I’d get your data working, maybe borrow an ecm and troubleshoot so you have some dough left when the actual problem rears it’s head. There is a learning curve just take your time.
 

Flipped Auto

New Member
Joined
Dec 14, 2011
I'd be worried about oil pressure...after letting it sit for 10 years without priming the oil pump.
It was babyed before starting it up , pulled Valve covers, front cover etc but I definitely understand thats a worry I had. keeping an eye on it .....
 

TireFryer

I have a slow WH-1
Joined
Dec 21, 2001
I'd be worried about oil pressure...after letting it sit for 10 years without priming the oil pump.
Seems like so many people just start these up.... is it that hard to think about priming the pump so you have oil between the bearings??? :rolleyes:
 

jlat

Well-Known Member
Joined
Jun 3, 2009
hello people: you've done enough to drive the car and that's what I'd do. change the brake fluid and maybe the power steering. a good radiator is a must . did I say drive it and get a scanmaster. and as said go slow with replacing parts. were do you live? just curious.
IBBY
 

grass doctor

Dream Catcher
Joined
Sep 21, 2018
first order of business....is motor/oiling...maybe an engine clean with sea foam in oil...then drain and replace with VR1 or brad penn....next order of business is fuel system....then coolant flush with new stat and hoses ...and all general maintenance, then on to brake system if you want to drive it LOL...the tps is probably fine ....and the IAC can be cleaned as well as MAF....NEED scan tool to check perameters...have you read the sticky INFO FOR ALL NEW TURBO REGAL OWNERS....


there is all the info you need on this site ....but you have to the the time to read many things posted in each section.....and any query you have type in google and add Turbo Buick to the end and you will find many threads...from our great site....one must be very detail orientated when dealing with a 30 plus year old car and especially a boosted motor....cheers...and congrats on your new car ...it is a piece of American muscle car history....
 
Last edited:

Flipped Auto

New Member
Joined
Dec 14, 2011
I REPLQCED THE ECM - INOEFT THE FAN RELAY AND TCC CONNECTOR UNPLUGGED ****SCANMASTER IS NOW READING DATA***

I was adjust tps to .46
***noticed harness seems to be flipped *** the actual clip that secures the connector is missing ..looking at the tps does anybody know wiring colors top to bottom ????? id appreciate it...

will be installing adjustable FPR NEXT !!!!!



thanks for all the input I appreciate, just trying to get it running good for now and then down the road do some upgrades ...
 

Flipped Auto

New Member
Joined
Dec 14, 2011
hello people: you've done enough to drive the car and that's what I'd do. change the brake fluid and maybe the power steering. a good radiator is a must . did I say drive it and get a scanmaster. and as said go slow with replacing parts. were do you live? just curious.
IBBY
Kansas city MO
 

SCOOBY DOO

I'M NOT A MONSTER, I'M JUST AHEAD OF THE CURVE!!!
Joined
Feb 18, 2007
I REPLQCED THE ECM - INOEFT THE FAN RELAY AND TCC CONNECTOR UNPLUGGED ****SCANMASTER IS NOW READING DATA***

I was adjust tps to .46
***noticed harness seems to be flipped *** the actual clip that secures the connector is missing ..looking at the tps does anybody know wiring colors top to bottom ????? id appreciate it...

will be installing adjustable FPR NEXT !!!!!



thanks for all the input I appreciate, just trying to get it running good for now and then down the road do some upgrades ...
You can see the wire colors at 4:50 on my video.

How To Change Fuel Injectors - YouTube
 

Flipped Auto

New Member
Joined
Dec 14, 2011
I did end up finding wire colors and got it adjusted, it just confused me because it looks like the clip on the plug should go the other way...hopefully the pictures load
 

Flipped Auto

New Member
Joined
Dec 14, 2011
when I was replacing the ecm and swapping the chip over, noticed it had a (pitbull atr) chip... from my research i havent seen alot of good reviews about them ... thinking I may go with the TT 42LB INJECTORS AND CHIP ???? wondering if the chip may have something to do with my idle (rough) along with my IAC being way out of adjustment, didn't get to to operating temp was just scrolling threw the data on scanmaster , showed iac at (150) !!!!! ?????? after I got the scanmaster data working..didn't run it long at all

any way to identify injectors without pulling them ?

fresh fuel and fuel tank
maybe the chip is for a different octane???
 

Pronto

You can't knock them up with spit.
Joined
Dec 9, 2002
I would go to 60s. They have proven to idle better and have all the head room to run low 10s.
 
Top