Knock Sensor & TA block

tom j

Active Member
Does anybody use one with a ta block and a solid roller cam. Or is it just a waste of time?
 

jjkv

Member
Does anybody use one with a ta block and a solid roller cam. Or is it just a waste of time?

Yes, I do use one on my TA Block and yes I do have a solid roller cam without any problems. I just use it for tuning purposes ..using race fuel most dont need/use it. But it is good insurance to know if there are any other audible problems...hope that does not happen..
 

TurboTR

sprayhead
Well it's not really added insurance because it doesn't work right. False triggers at part throttle, then goes silent at WOT when you need it (lol).

The factory supercharged '03-'04 Cobras don't have knock sensors, nor even the boss cast on the block for the sensor if I recall. Same problem- too much background noise to be of any use.

TurboTR
 
Hmmm, I have one on my Stage 2 with solid lifters, solid midplate and solid motor mounts etc... when driving around the gauge is going off into the green, then sometimes yellow and red. When I am into in even around half throttle it doesn't come on. I was assuming that when the engine was under load it was running well and not detonating.... am I wrong in assuming this?


:confused:
 

TurboTR

sprayhead
That was my experience too basically with solid lifters. It may in fact be running fine at high load, but don't expect to use the knock system to tell you yes or no on that in my opinion.

TurboTR
 

jjkv

Member
Hmmm, I have one on my Stage 2 with solid lifters, solid midplate and solid motor mounts etc... when driving around the gauge is going off into the green, then sometimes yellow and red. When I am into in even around half throttle it doesn't come on. I was assuming that when the engine was under load it was running well and not detonating.... am I wrong in assuming this?


:confused:

Try putting some ocatane in to see if if it really is due to detenation or if it is something else. My knock gauge was doing the same,,,turned out to be my down pipe rattling under the car.

I too have solid lifter with no problems :)
 
Top