Intake Manifold

deenasty

Member
Hey Guys, first and foremost thanks for reading and taking your time, which I know is valuable. I just finished up a small build (TA49 HD Actuator, PTE SLIC, Alky, etc.) on my GN. It is tuned via TT. I am having a an issue, that I will try my best to describe. When I am coasting on the highway at steady speeds, and slowly get into the throttle, the boost gauge goes crazy in low boost levels (0-15lbs). This issue is not an issue at WOT, or when it isn't slowly building boost. I have attached a video of my boost gauge, so I hope it helps. Any idea or suggestions would be greatly appreciated. Here is a link to the video on youtube:

GN Turbo Flutter
 

pacecarta

LOGGED OUT
Staff member
very common TA 49 issue once boost is raised above stock ..its compressor surge from throttle blade restriction, feels like a bucking when trying to accelerate like to pass a car but not blow the tires off , i hated it , with speed density it seems to never occur because the MAF is not there reacting to the surging which then changes the fueling and then repeats
some have suggested using a tornado in the maf pipe infront of turbo to prevent the maf from getting confused
 
Last edited:

deenasty

Member
very common TA 49 issue once boost is raised above stock ..its compressor surge from throttle blade restriction, feels like a bucking when trying to accelerate like to pass a car but not blow the tires off , i hated it , with speed density it seems to never occur because the MAF is not there reacting to the surging which then changes the fueling and then repeats
some have suggested using a tornado in the maf pipe infront of turbo to prevent the maf from getting confused


I too thought that what I am experiencing was compressor surge, until I turned the alky off and noticed that the flutter was hardly there at all. I am starting to think that the car is a bit rich, and the alky is making it richer and therefore making the problem worse.

I contact Julio and he suggested I turn the "turn on" a bit, since the kit was activating at 5psi, and he suggested it come on at about 8psi and lower the gain knob from 7 to 5.

I will be bringing the boost down to about 16-18lbs and try and get the fueling and alky dialed in first, before raising the boost any higher. Does this sound like a solid idea?
 

Pronto

You can't knock them up with spit.
Yup right around 12psi is when I would get it with my old set up. Had to either stay at 10 or power through it to 15 or so. I did the Tornado and it helped.
 

1KWIKSIX

Well-Known Member
This is the reason I opted for an S ported shroud on my turbo purchase when I upgraded mine.
The ported shroud on my DBB5857 Precision Turbo prevents such an occurrence.
 

Pronto

You can't knock them up with spit.
Yes, the ported cover wasn't available back when I had my 6131. I'm sure it would have eliminated that issue.
 

fitz3820

Active Member
I installed the tornado and it does work - crazy but it made the car 98% more smooth during part throttle acceleration
 

MikeS

Active Member
I am having a similar issue as the op. Do you have a part number for the tornado you used? Thanks
Check ebay, you just need the one that matches the inside diameter of your intake pipe. I picked up a used 3" one for $10, it looks like all the ones on there now are $30-50.
 
Top