I tried to fix what wasn't broken!

Jon Early

Active Member
I bought my 86 with a very poorly installex alky control kit. I tried to clean up the rats nest of wiring and now things are acting very odd. With the key on the power injection light is brightly illuminated all the time, but the pump is not running. The progressive led lights up green when I press the test light, but still no pump action. I've checked and rechecked my connections, and compared them to the manual. However, nothing seems to be wrong. I'm calling it a night, but if there's a wiring diagram for alky control kits out there I'd love to see it before I tackle this problem again tomorrow. Thanks in advance!
 

Jon Early

Active Member
Try not to let it get to you.

My car has kicked my @SS a few times also.
This car has made me want to pull my hair out over the last few months and that's why I had to quit for the night. I'm sure this problem will make me feel silly once I find it though.
 

GNRick

Retired member
Sounds like either a blown fuse or bad ground. Maybe the previous owner installed an inline fuse that blew. I also found that not just any ground location will do. I found it best to use the screw under the dash to the left of the headlight switch.
 

Chuck Leeper

8/10's of a century!
Staff member
Take it ALL out, clean up the wiring, and start over w/ the installation sheets.
While you are doing that, send the pump to Julio, for a rebuild.
I work at Hot Muscle Wiring, a small hot rod wiring shop. We find rats nests in most all the cars that come in for some "minor" issue.:rolleyes:
Almost, without fail, 1 fix leads to another issue, to yet another. Many times, we have to start over, or don't do the job.
Most "famous", the infamous butt splice, w/ 6" of odd wire in between it , and the next splice.:wtf:
 
Top