Help with rotating rattle noise coming from trans, bouncing pressures VIDEO

Hi all,
Went to go for my Saturday morning drive and heard an awful rotating/rattling noise coming from the converter/ pump area on startup. Car was previously driven about a week ago and had steady pressures, 100 psi min and would go 260-280 full tv. Tv cable is adjusted properly as i had no shifting issues prior. Trans is an ea 2004r stage 2 with ptc 9.5 nlu 17 blade bought from a fellow board member about a year ago. Put about 50 or so easy miles after completing the hybrid swap. Fluid is dex 6 and is up to the full mark. Been run with an external cooler after the radiator cooler and an external filter right after the external cooler, so this trans has never seen unfiltered fluid in my hands. Temp gauge sending unit is mounted right after the external filter and trans has never been above 170-180 def F. I am sure its coming from the trans as i removed the converter bolts and the noise went away. Pretty sure im missing something, but ask away. Pan is dropping right after this post. Could a pump make this noise? Sounds more like the convertor came apart.

Here is a link to a video i took this morning:
 

INEEDAGN

Seen Your Member
The odds of the pump being salvageable with that noise and that pressure gauge bouncing are pretty slim. Trans is going to have to come out and the pump pulled and inspected.
 

Chuck Leeper

Toxic old bastard
Staff member
The odds of the pump being salvageable with that noise and that pressure gauge bouncing are pretty slim. Trans is going to have to come out and the pump pulled and inspected.
And, the cooler changed, along w/ the converter cut and cleaned.:(
 

INEEDAGN

Seen Your Member
This is why everyone has so called "billet-itis" in the trans. One part failure screws you out of a lot of money.
 
Top