Have a powerlogger and car acting weird? Look inside.

garyk1970

Electronics Moderator
Staff member
I recently bought a 87turbo Regal and it’s been having interment issues. Long start, bogging on acceleration, and rich .
It acted up yesterday and I tapped on the pcm housing and the car started fine.
Time to check the powerlogger to pcm board connections.
I took the pcm apart and wire brushed the circuit traces where the PL mates to the board.
Now to my extra pro tip; I actually solder the traces to build up thickness on the board to help conductivity.
Then I wire brush again, secure the PL with hot glue, and reassemble.
DO NOT LET THE TRACES TOUCH FROM TOO MUCH SOLDER.
Fixed another car, hasn’t acted up again.
Hope this helps someone, cheers.
 

Attachments

Pronto

Chaos is a ladder.
That's a great fix! I don't know if I would trust my soldering skills with electronics though. Is there an antiflux that can be painted between the fingers to keep the solder in place?
 

garyk1970

Electronics Moderator
Staff member
That's a great fix! I don't know if I would trust my soldering skills with electronics though. Is there an antiflux that can be painted between the fingers to keep the solder in place?
Thanks, I’m not sure... I used a fine tipped soldering iron.
I have soldered two circuits together that were close before, I used a razor blade to cut a path between them.
 

wb_7354

Active Member
Nice job! I know lots of guys have a issue with that PL connection. Personally I don’t think I could do it.


Sent from my iPhone using Tapatalk
 
Top