External trans cooler

1984 t-type

Murphy's Law
I bought a used engine after i broke my crank, the engine came with a newer MAF transator and a questionable MAF sensor. So i bought a new sensor and got the car up and running, can ran good and all of my scanmaster numbers looked ok, BLM and INT both held at 128. Now while i was in the process of going over everything i opened up the translator to see what it was set at, the translator setting were for a extender chip and a 3.5 MAF. I changed the settings to match my setup Turbo tweak chip and 3'' MAF, now my idle surges when in park it will drop from 900 to say 600 and come right back up and my BLM is at 142, INT fluctuates but today it was at 128.

I have had this new setting for a week or so and drive the car 10-20 miles daily so its had time to learn also reset the computer. My logic tells me to put the settings back where they were but what would cause this ? At this point i just want it to run right but i know the previous settings are not correct for my setup. Oh i also added 10% more fuel via the translator and have played around with the fuel pressure, neither of those seemed to make a difference. Also not sure if this is related or not but i noticed sometimes when i come off the throttle my rpm's drop a little low then come right back up, for instance when in third gear or overdrive if i let off the throttle the rpm's will drop to around 900-1000 and then go up to 1500 where they would normally be. I cant remember if this was happening before i changed the translator settings or not.

Anyone else seen this before, what are your suggestions ?
 

Fatpig

Member
Did you ever figure this out? I am having a very similar problem with my car except my rpms drop so low it stalls. The af reads 10.0 when this happens like it is flooding the engine.
 

1984 t-type

Murphy's Law
Did you ever figure this out? I am having a very similar problem with my car except my rpms drop so low it stalls. The af reads 10.0 when this happens like it is flooding the engine.

Think mines was just a matter of something else happening to go wrong when I made that change and was unrelated to the translator. My issue wound up being a vac leak at the EGR block off plate. I had to pressurize the system to find it.
 

1984 t-type

Murphy's Law
There is a piece you can buy but I made my own out of a bolt in valve stem and some plumbing pieces. Keep saying I’m going to buy 1 but when I need it I need it right then and can’t wait on shipping. I had 1 blow out a few years ago At about 25psi fun times lol ! Won’t let me upload a pic of mines but pm me your number if you want a pic and in the mean time I’ll see if I can remember where I saw them for sale and post a link. Good tool to have you will find leaks for sure.
 
Top