E85 car tuning

joeb1300

Member
Take the cap off the cam sensor. Grab the metal reluctor ring and see if you can spin it by hand. If you can spin it then you have broken the "tab" off the reluctor ring which is there to hold the reluctor ring in phase with # 1 piston at 25deg of rotation after top dead center. This is a typical issue with a stock cam sensor and causes backfires.
Ok would the car still run good just driving around town?
 

joeb1300

Member
Took cam sensor cap off can't spin it but has little play. Marks dont line up. Is this ok? Looks a little off?
 

Attachments

  • 1440703628822.jpg
    1440703628822.jpg
    26 KB · Views: 136

joeb1300

Member
Can someone tell me if i hook up the boost gauge output to map input on dataligger is ok or do i need to run all three wires from the switch? Also how do i hook this logger up if i don't have an old windows computer. Drivers can load.
 

dynoman

Well-Known Member
Also on this power logger how do i add fuel pressure and boost to the inputs ? Both are aftermarket aem brand.

For boost pressure use the green wire from the MAP sensor to #2 input on the Powerlogger break-out board .
For fuel pressure I was told you could take the signal wire from the transducer that goes to the gauge and use that for a analog input to the Powerlogger (#4). Break into those wires and branch off of them to the Powerlogger . I have not done the fuel pressure logging yet , maybe someone else can help , but this is what I was told . good luck , Sam
 

joeb1300

Member
Ok will do that. I have a output wire from my gauges hooked it up with those but car now runs like crap. Eric thinks its my maf which is me 2nd advance auto in two months. This car is testing me.
 

Jerryl

Tall Unvaccinated Chinese Guy
. . . Eric thinks its my maf which is me 2nd advance auto in two months. This car is testing me.
Eric does not think it's bad, he knows its bad based on the data that was provided?

If I was starting out, and reached out to one of the best in the business, I would trust his advice and the process.

These cars test /have tested EVERYBODY! LOL
 
Last edited:

joeb1300

Member
Oh i trust eric he has spent most of yesterday e mailing me. I dont trust advance auto. Wondering if i should just get a ls1 maf and translator. But that more computer electronics. Lol
 

Jerryl

Tall Unvaccinated Chinese Guy
Oh i trust eric he has spent most of yesterday e mailing me. I dont trust advance auto. Wondering if i should just get a ls1 maf and translator. But that more computer electronics. Lol
There are a few options;
-Translator and LS1 MAF - 1:1 success ratio probability
-Exchange Advance MAF (1:15 chance of success)
-SD chip or aftermarket - Eliminates MAF but more electronics.
 

joeb1300

Member
How do i delete maf? Is this plug in or more to it than that? Trying to get my car running a base line first. Might just buy a new coil and definitely a solution to my maf.
 

Jerryl

Tall Unvaccinated Chinese Guy
How do i delete maf? Is this plug in or more to it than that? Trying to get my car running a base line first. Might just buy a new coil and definitely a solution to my maf.
Deleting the MAF requires a new chip and wideband, 3 bar MAP, PL (looks you have that) and knowledge.

For jus a baseline . . . Keep the MAF system. Go translator and LS MAF. There area few things that are off as well on the screen shot. IAC for one is too high.

Go to Vortex Buicks, Turbotweak website, and read everything. A local buddy to swap parts is also a good idea . . . Besides sharing knowledge and experience.

Good luck.
 

joeb1300

Member
Dang intercooler pipe came off the bottom. Can you tell me if this looks better?
 

Attachments

  • 1441643805200.jpg
    1441643805200.jpg
    67 KB · Views: 129

gtfrede

Designated LSX Hater
That log file is pretty good....i would put money in cam sensor phasing is out....ive had your exact problem more than once and each time it was cam sensor not adjusted perfect....only other boost related ignition problem ive had was fixed with a new coil pack.
 

joeb1300

Member
I have another cam senor cap that doesnt have a light on it that came off this motor when we rebuilt it. Doesn't look like it has adjustment to it. Can i put his on instead of the red light caspers style?
 

joeb1300

Member
I just noticed a knock count of 1. Is this normal my scam master has never read anything but zero. Also any reason why gas gauge doesn't read after logger was installed?
 
Top