Dakota VHX, FAST XFI 2.0 cruise control, TCC, Speedo

THAWK

New Member
Jun 6, 2004
9
2
3
Prosperity South Carolina
Anyone running Dakota VHX dash with FAST XFI 2.0 and know how to enable Cruise and TCC to function correctly? I eliminated speedo cable and factory optic sensor. I was using the Dakota speed sensor hooked to my 200 R4 and still using the green factory VSS which fed signal to factory ECM for the signal that enabled cruise above 35 MPH and TCC above 45 MPH . My cruise and TCC worked perfectly before installing the FAST unit last week. I believe the FAST needs a signal from the factory VSS but I am not sure how to accomplish this. Any help would be appreciated. I can't stand for something not to function correctly.
 
Jan 31, 2006
7,085
225
63
L.I NY
Anyone running Dakota VHX dash with FAST XFI 2.0 and know how to enable Cruise and TCC to function correctly? I eliminated speedo cable and factory optic sensor. I was using the Dakota speed sensor hooked to my 200 R4 and still using the green factory VSS which fed signal to factory ECM for the signal that enabled cruise above 35 MPH and TCC above 45 MPH . My cruise and TCC worked perfectly before installing the FAST unit last week. I believe the FAST needs a signal from the factory VSS but I am not sure how to accomplish this. Any help would be appreciated. I can't stand for something not to function correctly.
TTT
Very interested in your solution.
I am looking to get a Dakota dash soon, I already have XFI and have no problem with CC or lock up.
 

THAWK

New Member
Jun 6, 2004
9
2
3
Prosperity South Carolina
Update, all good with FAST system and cruise. Ended up being a pinched wire from multifunction switch that got trapped under blinker switch when new ignition switch was installed. The exact setup I had working with factory ECM now works perfectly with the FAST.
 
  • Like
Reactions: TURBOPOWERED68