Clock staying on? Battery drain? Look no further.

garyk1970

Electronics Moderator
Staff member
Ive seen this issue alot,and havent been able to find this page/fix and post up...Thanks goes out to RmvBfrFlght for finding and posting up this link..... Now a Sticky.:biggrin:



copied from David Ellis' web site;

Battery Drain? … If your radio clock stays on with the key off, then read on. By David Ellis member LSPBC Dallas



If the Radio Clock stays on with the key off, then if your car sits for around 3 days or more, it will not start. So what you end up doing is you jump start your car and then go driving around for fun and to charge your battery. To fix this problem you can just disconnect the battery each time you put the car up, but that is a pain. This battery drain drove me nuts and so I put lots of time into tracking this problem down. I knew that the drain was around 350 milliamps and it have to be something that happened due to age to the car to cause the problem OR when the car was new everyone would have just taken them back to the dealer to fix the problem. In other words the car did not come with this problem. I did pull fuses until I found the problem circuit and it was on the CLK fuse. The CLK has lots of circuits on it and is one of the two power sources to the Radio. This circuit remembers the radio stations, time and the radio will not work with out it. I remembered that GM car radios that have a clock go off, if you turn the key off, and you can push in the volume knob to get the time with the key off. So I went back to the Internet to search for problems with the GM radio clock. I found the there are tons of Turbo cars out there with this same problem and lots of guy with the wrong ideas as to what is wrong. I found that there is a circuit that controls the clock that some guys had this fixed by a radio shop but they really didn’t know what was fixed. I have had this problem for years and I wanted to know all about it. I searched more on the internet and found one small e-mail talking about a transistor in the radio causing the problem. I traced the guy down and called him in Kansas and he told me which transistor it was. I then pulled my radio and replaced the shorted transistor and clock goes off when the key is off. I can let my car sit for weeks and it will still start, and it’s a healthy start. There is now no battery drain period. So I found the problem and here is how to fix it. Look at the rear of the radio in the first picture and you will see what looks like two Pac-Man and above the lower Pac-Man is a cut out or cave and just inside the cave you will see the little problem transistor in the second picture. Go to a Fry’s or any electronics supply store and buy one NTE232 transistor, should cost $.49 or so. You will need to take the metal covers off the radio and remove the old transistor (NOTE the flat side of the transistor) using a pencil type solder iron by touching the ends of the soldered wires while lightly pulling on the transistor from the other side. If you do this right and are lucky there will probably three little holes that you can put the leads from the new transistor in. Leave the leads on the new transistor a little longer that the old one you just pulled out and replace with flat side facing the same way as the old one. Touch the ends from the other side with the soldering pencil and add a small amount of solder on each of the three leads. Do Not leave soldering iron on any lead very long as heat will travel down the wire and destroy the transistor.

David Ellis
 

Attachments

  • picturesLIVE45_004.jpg
    picturesLIVE45_004.jpg
    54 KB · Views: 1,221
  • picturesLIVE45_016a02.jpg
    picturesLIVE45_016a02.jpg
    26.3 KB · Views: 1,197
  • picturesLIVE45_013.jpg
    picturesLIVE45_013.jpg
    81.8 KB · Views: 1,165
  • picturesLIVE45_015.jpg
    picturesLIVE45_015.jpg
    64.9 KB · Views: 1,208
  • picturesLIVE45_017.jpg
    picturesLIVE45_017.jpg
    55.6 KB · Views: 1,148

garyk1970

Electronics Moderator
Staff member
more pics

.
 

Attachments

  • picturesLIVE45_018.jpg
    picturesLIVE45_018.jpg
    77.9 KB · Views: 956
  • picturesLIVE45_019.jpg
    picturesLIVE45_019.jpg
    61.3 KB · Views: 984
  • picturesLIVE45_024.jpg
    picturesLIVE45_024.jpg
    67.9 KB · Views: 977

cruzn57

Still plays with cars!
GM is still putting out retarded radios. my 2013 Impala it will drain the battery in a few days,
car is 6 mos old! took it to the dealer, they couldn't find anything the 1st time.
so I researched it, and took it back, after it died 3 times in one month .
this time I told them look in the radio / amplifier area, (it has a Bose system)
and bingo, amp stay's powered on ALL THE TIME.
now on order ( of course they wouldn't be in stock)
 

LEGACY_GN

Active Member
I just wanted to say I came to this forum to research aftermarket options and am delighted to see this as I have been asked many times why my clock stays on all the time and no one else's does. However even when I only drove it once a week the batter never died so it never bothered me. Just seemed odd mine was like that. Anyway, it's time to upgrade. Thanks for the post though. Very interesting.
 

garyk1970

Electronics Moderator
Staff member
You're welcome guys, I'm seeing this issue more as our radios get older....I've never repaired a Delco radio with this issue before, I saved this because I'll run out of good radios very soon, and will have to start fixing them....man if I could go back in time when these cars were new, I was a new radio installer at a local stereo shop, I threw away a fortune of OEM radios.
 

LEGACY_GN

Active Member
I just took all the stock parts down from my attic and plan on selling them. Tired of the space they take up and I'm never going back anyway. There's so many of these cars and so many that were kept I just don't see the stuff ever going up that much. Just my .02
 
[QUO5TE=",xsn, am post: s,u Dr j x5 itu 4: 27088"]Gjr
zc,I'm MN; z
S Post !! I did this fix about 6dt7 yea7s 11rs agoz from inf c. Ce8o posted on m -zffxz-zcg zz. Clockfll sspe8ke -zj cd ddsd ex j perfectlyil6, no issues9m $.[/QUOTE]fin-zz
Z.
?cI
 
Hey Guys ..... happy it worked for you and that is why I put it out there.
I wrote it years ago .. I have had my WE4 for over 22 years and that issue with the
radio drove me nuts and I spend some time tracking down the problem on the car
and on the internet. I can say that I have the same radio and never had a problem since.
car can sit for months and still start...
Later
David Ellis
 

GString

New Member
I just wanted to shout out a big Thank You for this post. I recently purchased a one owner, 16,000 mile GN and it had this very problem with battery drain. After reading through these well written instructions, I ordered up a new transistor and with help from one of Electronic shop techs at work, we replaced the failed transistor and reassembled the radio. It now works properly with no drain. Thanks again!!!!!!
 
Top