Bad Gas causing ping?

Cape Cod GN

Member
Joined
May 21, 2014
Hi all I’m just looking to see if bad fuel can cause a pinging at WOT?
I have Meth injection (working I primed before the test).
43psi fuel and pushing
20 lbs of boost
outside temp was about 52 degrees.
I fueled up a couple weeks ago at a side rd gas station. So I’m thinking it might be the fuel. It has never done it before.
car still pulls and gets rubber rolling at 20 mph. But at wot I can hear a mild ping noise could it be detonation?
 

captndave737

Well-Known Member
Joined
Feb 14, 2006
Could very well be. Are you logging anything? Do you have a scanmaster? I've had that happen a couple of times. Car running great, Pull over and get some gas and then pings like hell. Stayed off the boost till I was low on gas, refueled and all was ok> That was vefore I had Alky. Have you tried adding more Meth?
 

Cape Cod GN

Member
Joined
May 21, 2014
Could very well be. Are you logging anything? Do you have a scanmaster? I've had that happen a couple of times. Car running great, Pull over and get some gas and then pings like hell. Stayed off the boost till I was low on gas, refueled and all was ok> That was vefore I had Alky. Have you tried adding more Meth?
Hi Thanks, yes I added more alky. I was between 6-7 on the dial and bumped up to 7-8. Still did it. Do you know If that octane boost stuff works? I have a full tank...lol.
 

captndave737

Well-Known Member
Joined
Feb 14, 2006
No Idea if that stuff works. When it happened to me i was on long trips so burning through a tank wasn't an issue.
 

Jerryl

Tall Chinese Guy
Joined
Dec 14, 2004
Put alky back to 6.5 and
pull timing back ~3 degrees in all gears and monitor. If you still get KR on the scanmaster, lower boost.

This all assumes the ignition, alky and fuel system are at 100%.
 

SCOOBY DOO

I'M NOT A MONSTER, I'M JUST AHEAD OF THE CURVE!!!
Joined
Feb 18, 2007
Post your SM numbers with the engine warmed up. Are you seeing the fuel pressure rise 1 for 1 with boost. Did you see KR on your SM and what was your 02's. I assume you hit recall on your SM to show 02's and any KR.
 

dynoman

Well-Known Member
Joined
Nov 30, 2009
Back in 1986 my wife took the GN somewhere and decided to put gas in it . After she got back I went for a ride and it started pinging during a blast on a highway on ramp ( 18PSI ) . I immediately knew she put in the cheap stuff , so I went and put in a bottle of octane booster and the problem went away . She didn't drive it much after that !!
This is all I have left of the old girl.
20200422_135744.jpg
 

hensleyt

Well-Known Member
Joined
Feb 20, 2008
It’s not that hard to siphon the fuel out and put it in your daily driver. 4foot of 3/8 clear hose is chipper than octane boost. Clear so you can see it coming
I siphon my GN before every race to have fresh fuel
 

joed

Active Member
Joined
Mar 6, 2002
Should not get KR with 20 psi and Alky at 52 degrees. Check your alky pressure...what system? How old?
 

Pronto

You can't knock them up with spit.
Joined
Dec 9, 2002
You have a Scanmaster I hope...
Turn down the boost until you figure out why it's pinging.
Get a tester from Julio. You could have a leaking alky system.
Drain the gas and try some from a station that's busy.
 
Top