Alternator not charging after LED

Hey guys
I upgraded my GNX clone dash with LED lights
Very nice increase in brightness
But.....
Seems that the alternator stopped charging due to the LED resistance not the same as stock bulbs
I'm going to switch the volts light bulb back to see
Battery is spent and have to be replaced
Hope alternator is still good
How to check?


Sent from my LM-V405 using Tapatalk
 

chopped39

Well-Known Member
John Spina AKA GN Venom sometimes sells a bulb with resistor. Maybe you could use that with the led. Caspers electronics
 

Jerryl

Tall Unvaccinated Chinese Guy
Hey guys
I upgraded my GNX clone dash with LED lights
Very nice increase in brightness
But.....
Seems that the alternator stopped charging due to the LED resistance not the same as stock bulbs
I'm going to switch the volts light bulb back to see
Battery is spent and have to be replaced
Hope alternator is still good
How to check?

Sent from my LM-V405 using Tapatalk
Great catch!
Just revert back to the bulb (194?) and call it a day. It only lights up KOEO anyway, unless of course there is a problem.

Alternator can be verified on the car with a volt meter.
 

Pronto

Believe nothing you hear and half of what you see.
If you still got the bulb with the resister and it's ok then put that back in. New bulbs are impossible to find unless John has another run of them. Last time we bought a few of them to have on hand, otherwise the his field fix will work.
 

mikestertwo

Well-Known Member
If you wire in the 3 wire regulator connector you will be able to use the LED lamp and the alternator will still charge.
 

RmvBfrFlght

Well-Known Member
Leaving the LED bulb and installing the field fix kit is the best way to go. The original setup with just the bulb is a disaster: if the bulb burns out or fails to make contact with the film, or the film to dash connection becomes flaky, still end up with a dead battery.

Not so with the field fix installed.

RemoveBeforeFlight
 
Thanks all
Caspers field fix ordered
On sale and free shipping

My alternator and battery were both shot


Sent from my LM-V405 using Tapatalk
 
Top