87 Grand National Woes - S/SE Houston Area (Angleton)

Bone_Enterprise

New Member
Hello all, long time lurker somewhat recent registrant and GN owner.

Been a long time dream of mine to own a GN, and as of September of last year finally made that a dream a reality, shortly thereafter began my nightmare of owning this car, essentially going to cliff notes this so the wall of text is not as big as it already is going to be.

Will preface this with that I am ignorant as hell when it comes to knowing things about anything mechanical related on vehicles, other than extremely basic stuff, so really have been relying on suggestions from people I know, and what I get told by the shop(s) I take it to, to my knowledge and from what I have been told by the person I purchased the car from, it is/was stock, short of aftermarket gauges.

Things that have transpired so far (major issues begin at fourth notation):

1) Ground wiring harness came loose, rested on exhaust, melted in two.

2) Alternator died, and replaced.

3) On same visit as alternator was replaced, it was noticed that the turbo was coming unbolted from the mount, and was torqued back down.

4) Motor blown, threw two rods, one of the piston heads was damaged, cracked the head, and the crank needed to be replaced.

5) Car was taken to a local shop, motor removed, sent to Jasper Engines and had an authentic rebuild performed. (Late December)

6) Motor gets returned, put back in, then begins work on some of the small things I wanted to get taken care of in addition to the rebuild:
a) Oil pressure and water temp auto meter gauges had not been working since I acquired the car, they were able to get these working by actually running the damn wiring harness into the engine bay and wiring it up, wonderful oversight by whoever put it in to begin with.​
b) Car had a +60PSI autometer gauge, I had them replace it with a -30/+30PSI autometer gauge I purchased and brought to them.​
c) Purchased and had them install a wideband AFR autometer gauge.​
d) Purchased and had them install a replacement ignition cylinder lock.​

7) Go for my first test drive after the rebuild is done, round the corner to go down the street, car sputters, car dies again, determined to be the timing gear that comes off the end of the crank shaft had shattered, this was caused from the harmonic balancer grinding on the crankcase cover and putting stress on said gear and other shit. This was because Jasper forgot to put back a shim that goes at the end of the crankshaft, just before exiting the block, and giving the crankshaft the small amount of tolerance to shift forwards when the harmonic balencer was torqued down to put everything off enough to destroy itself again, motor got removed and sent back to Jasper Engines a second time as they wanted it back.

8) Motor comes back, gets reinstalled, I go pick it up end of their business day to take it home, the car stalls out four times within 8 miles, return car back to shop, problem assumed to be the idle air control valve, so that was acquired and replaced.

9) Work was complete, I go pick up car and have the owner of the shop do a ride with me, car _only_ stalls once during our outing, I okay the work thinking it was a one time event, take him back to the shop, then go and ride around myself for a while, the car begins to stall out again but only in a particular scenario, which once I figure it out, can replicate every single time, I go back to the shop, and drop it off again. (this was yesterday)
a) Problem can be replicated by accelerating to second gear (25-30MPH), letting off the throttle, and then everything shuts down (made a video of this), this happens every single time.​

Which leads me to this post, what the actual fuck over?
Where do I go from here, I already had to take out a personal loan from a family friend to pay for the engine rebuild, in addition to the loan I took out to buy said car, so my available disposable income is pretty much wiped clean, I am at my wits end on this car and all of this has driven me to a point of which I am ready to get it fixed and sell it.

With all that being said, my question is three fold:
1) Does this sound like a tuning issue with the turbo since the motor has been rebuilt?

2) As the title says, I live S/SE of Houston (in Angleton), does anyone in the area have a reputable place they would suggest I take the car to and get it tuned, looking back a few pages I saw Westside Performance & Machine mentioned? (at this point I don't care if it is not a shop, as long as it is done right)

3) I made a video of my AFR gauge and showed it to my friend as was asking what it was reading, and he told me it seems to be stuck in a loop and doesn't seem to go into a closed loop, it reads 10.0 when driving at a consistent speed and stays there, only time it goes up is when you let off the throttle, or are at idle, could this also have to do with the potential bad tune?

I am sure I forgot some shit, but this is enough wall of text as it is, hope this part of the forum is still active enough for this to be seen.

Help me before I go launch this thing over a bridge or something!
 
Last edited:

Bone_Enterprise

New Member
There was already a bung in place (with nothing in it), roughly 14" (my estimate) or so away down from the turbo, so they put it there.
 

Bone_Enterprise

New Member
Tried calling Westside Performance and after talking with Clete, it is not an issue they can help with, but name dropped JD Brooks, I assume that is you @JDSfastGN ?

Do you have any input on a problem like this, or suggestions/advice on where to take said car?
Also Mike Hurtz at Centry Automotive was named, has anyone used/heard of him/them?
 

JDSfastGN

Well-Known Member
Tried calling Westside Performance and after talking with Clete, it is not an issue they can help with, but name dropped JD Brooks, I assume that is you @JDSfastGN ?

Do you have any input on a problem like this, or suggestions/advice on where to take said car?
Also Mike Hurtz at Centry Automotive was named, has anyone used/heard of him/them?

That would be me. Yeah westside is just a machine shop and doesn't do any of the actual on car work. Shoot me a private message or give me a call sometime. Between 5 and 530 im on my way home and after 8 the kids are asleep. . Im a ways away up in Cypress but its probably a simple issue.
 
Last edited:

Bone_Enterprise

New Member
That would be me. Yeah westside is just a machine shop and doesn't do any of the actual on car work. Shoot me a private message or give me a call sometime. Between 5 and 530 im on my way home and after 8 the kids are asleep. *******. Im a ways away up in Cypress but its probably a simple issue.
I'll give you a call, got your number jotted down if you want to remove it from public viewing.
 

robertf

Active Member
Lemme just say your very first mistake was not coming here first and asking questions before purchasing any GN.
Secondly, never buy a GN {or any car} without a working oil/temp gauge. Terrible decision.
 

VenomGT

That Youtube Guy
If you haven't resolved this and are not too far from Houston (Baytown area), I may be able to give you a hand the last week of June, I am heading south to help a buddy out with his Turbo Buick. PM me.
 

Bone_Enterprise

New Member
If you haven't resolved this and are not too far from Houston (Baytown area), I may be able to give you a hand the last week of June, I am heading south to help a buddy out with his Turbo Buick. PM me.
Baytown is an hour or so away from me, after talking with JDSfastGN he thinks it is a vacuum line issue, the car is still at the shop trying to get that rectified.
 
Top