2004r died - under 200 miles self built

CamaroMan

Member
hi all - man i thought sth was wrong on the last trip out.. anyway - went to move the car and took a drive around the block, when cold it drove fine, after heated up (10 mins) the car literally wouldnt move. Came back next morning and managed to JUST get it up the hill and back in driveway.

I followed chris's book but the tolerances were so darn tight and pics lacking - maybe sth went wrong. Had some sonnax pump upgrades up front, and the art carr kit/mods in the VB.. sonnax billet servo ( i should have opted for the adjustable one!)..

Possible i need to adjust/check the band / servo play of tranny toast? might drain a bit of fluid and check (i installed a drain valve).. wondering if hard launches with stock filter/pan are the issue too.. i dod do some REAL hard launches :)
 

CamaroMan

Member
ok sorry for the late reply- finally got the psi gauge hooked in this evening-

at idle in park psi is around 50, when i blip the TV cable by hand it jumps to around 235 psi- cant find my psi chart cos i moved my shop 2 months ago and everything is in chaos state incl my driveway which is full of engines-

i tried to get hold of a few o fthe guys but they seem very quiet about checking the 3 end plays, i own chris book and pretty much followed what i could-
 

Mr.Spool

Well-Known Member
ok sorry for the late reply- finally got the psi gauge hooked in this evening-

at idle in park psi is around 50, when i blip the TV cable by hand it jumps to around 235 psi- cant find my psi chart cos i moved my shop 2 months ago and everything is in chaos state incl my driveway which is full of engines-

i tried to get hold of a few o fthe guys but they seem very quiet about checking the 3 end plays, i own chris book and pretty much followed what i could-
Call dave husek,period.
Unless you want to keep chasing your tail.
But 200s are an art into themselves.
Others think they can build them untill real power is applied.
Good luck
 
Top