MikeS's latest activity

  • M
    MikeS replied to the thread Boost Maxes out at 20psi.
    What size turbo? Exhaust back pressure could be forcing open the waste gate before your target psi? I had to install an additional...
  • M
    MikeS replied to the thread New Owner.
    I'd recommend against taking your car to any dealership. I doubt most of the current dealer mechanics today have any experience with...
  • M
    MikeS reacted to grass doctor's post in the thread New Owner with Like Like.
    call or email Caspers electronics ...they can repair or send you a re calibrated /refurbished oem boost /tach gauge ....or you can...
  • M
    MikeS replied to the thread New Owner.
    My stock boost and tach lights at the lower right corner of the instrument cluster are pegged at redline/ full boost all the time. Even...
  • M
    MikeS replied to the thread Timing Question.
    I run 24 degrees in 1/2 and 18 degrees in 3rd (TH400 trans). Was at 25psi on 93/alky, currently 28psi on e85.
  • M
    Thanks, hopefully you can find one closer to home to avoid the shipping charge.
  • M
    Heater core sold. Turbosmart, I sent you a PM on the evaporator.
  • M
    I'll get back to you on shipping cost, I have to get a box to fit it.
  • M
    Damn that was quick. PM me your address so I can get a shipping estimate.
  • M
    I have a copper/brass heater core, just taken out of my 1984 T type yesterday. See first 8 pics, it has some minor fin damage but works...
    • IMG_2265.jpg
    • IMG_2266.jpg
    • IMG_2267.jpg
    • IMG_2268.jpg
    • IMG_2269.jpg
    • IMG_2270.jpg
    • IMG_2271.jpg
    • IMG_2272.jpg
    • IMG_2273.jpg
    • IMG_2275.jpg
  • M
    MikeS replied to the thread Boost Flutter?.
    Check ebay, you just need the one that matches the inside diameter of your intake pipe. I picked up a used 3" one for $10, it looks...
  • M
    I run an eBay fmic. Couldn’t tell you a brand, bought it about 10 years ago. Got the pipes for it separately. As with anything eBay...
  • M
    MikeS reacted to precizion818's post in the thread Do I need my factory harness? with Like Like.
    Hey, so I removed the turbo engine harness fully intact. I am replacing half the C100 connector on drivers side with a replacement from...
  • M
    MikeS replied to the thread Fuel.
    I went into more detail in the PM, but yes. I switched the lines in the engine bay and at the tank.
  • M
    MikeS replied to the thread Fuel.
    I’m not sure if the Walbro 450 would have been too much for the stock return line or not. But I’ve seen claims it could, so I did the...
Top