GNVenom
Joined
Likes
245

Profile posts Latest activity Postings About

  • Hello John my name is Tom,I have a 1987 GN with (dead ) digital dash.Id like to check the wiring for correct power before sending out.Can you provide a diagnostic quick check.Regards Tom 516-527-4114
    GNVenom
    GNVenom
    First, check the INST fuse.

    Then, check the pink/black wire for 12 volts on the connector that is directly behind the dash cluster. There is a plug-in that sits at an angle when the dash is removed. There is also a memory wire that's continuous 12 volts (same circuit as the radio station memory) that can be checked.

    A dead power supply is a very common problem with the digital dash clusters, however.
    John, This is Matt Holcomb I drove up last week and bought a cam cap from Justin. I'm having issues. No matter where I turn it the light will stay on. I reset my cas like how it is in the instructions with the window facing the driver head light. I read on a post that there was a issue with magnet strength. Please let me know if you can give me some help.
    Thanks
    Matt
    720-345-4857
    GNVenom
    GNVenom
    If you have an aftermarket ignition module, it could be the problem.
    If not, take the cap off the drive, turn the key to run, and pass a screwdriver thru the window slot under the cap. The light should turn off when the screwdriver blocks the slot.

    If it does, you may have a worn cam sensor drive.
    John
    matt921
    matt921
    John I figured it out. After fighting with it for a few days. Turns out my module was bad. It would start then die. Swapped out the module fired up ran perfect. Thank you for replying you and your company have helped me tons.
    Matt
    GNVenom
    GNVenom
    We haven't been able to get those gray connectors for many years. Long since obsolete as they were unsealed. What we recommend is that you replace the original relay, connector, and wiring with a current-production sealed relay.
    231REGAL
    231REGAL
    Thanks John!
    John, I have a custom wiring h arness from you for my fast xfi. How do I flash the new update on the xfi with this harness? I can do it by gounding the pin in the aldl connector right? I just don't remember which one I have to ground.
    Thanks
    sam
    GNVenom
    GNVenom
    Check with Cal Hartline. I believe you ground one of the terminals on the ALDL, not sure which though. Our harness is wired like the factory harness with regard to the ALDL.
    John
    Hey John, did you ever do that Dakota Digital write up for the GN?
    GNVenom
    GNVenom
    I didn't plan on one for the Dakota. Actually never saw one of them. I was going to do one on the GNX conversion, but haven't yet.
    Good day John. I have a question for you. I recently converted my 86 GN to a BBC. Since then, the digital dash hasnt worked. I eliminated the ECM harness. Obviously, I broke a loop by doing this. What do I need to power the dash? Everything else works. Turn signals, security light. I really need the dash for the speedo and fuel gauge. I read something about the (C437) clear connector behind the glovebox. Thanks, Jim
    GNVenom
    GNVenom
    There's a ground for the dash at the C437 connector. That connector was near the ECM and has 13 wires in it. The black with white stripe needs to be grounded, and the dash should work after that.
    Hello John,

    If you still have a vaccuum block available, I'd like one please. Please forward your paypal address via pm.

    Thanks,
    Chuck Meyer
    gnvenom,is there a fusible link from the starter that feeds the cigclk 20 amp radio 5amp and the taillps 20 amp fuses ? the reason I ask is that I have no power at these fuses or should I be checking the ground for these fuses also where would it be located ? thanks MORG87t
    I was told to contact you because you work at Casper's, and I was wondering if you could help me find a pigtail for 86 GN that I cant find anywhere, I am new to the website and if you don't mind I was wondering if I could have your email so I can send you the picture of the pigtail that I need, thanks. Dan
    John another question after install?? I have hooked up the battery testing the electrical system on the Atomic GN. I have tail lights and headlights, nothing else? No motor or trans. I grounded all grounds though and have HL&TL's What is wrong? Thank You.
  • Loading…
  • Loading…
  • Loading…