bison
Joined:
Dec 19, 2005
Messages:
14,426
Trophy Points:
113
Positive ratings received:
772
Neutral ratings received:
3
Negative ratings received:
7

Post Ratings

Received: Given:
Like 689 178
Dislike 2 0
Agree 42 0
Disagree 0 0
Funny 5 0
Winner 11 0
Informative 12 0
Friendly 4 0
Useful 5 0
Optimistic 3 0
Creative 2 0
Old 2 0
Bad Spelling 1 0
Dumb 4 0

Share This Page

bison

Moderator

Staff Member

Send me PM's Please. I never see these messages since im on the iOS app and this section isnt available. May 21, 2013

    1. Fast Farmer
      Fast Farmer
      enjoyed reading your posts on TE-44 max boost. If the 44 is out of breath with just a bowl clean up, what turbo does he need to keep up? Perhaps a TE-60? Reason I'm curious, is I am thinking of porting my heads, and I am also running a TE-44, and just want to keep things matched up right. I am going to keep the stock cam for now, though. What are your thoughts on this?
      1. oscar22 likes this.
    2. JTC
      JTC
      Question,
      Why can't I post pictures?
    3. 87Turbo-TWE4
      87Turbo-TWE4
      can you give me your email so i can send pics of these two stock turbos?
    4. bison
      bison
      Posting problems fixed so far
    5. bison
      bison
      New format is giving me big balls and cant post anything!!!
    6. jasjamz
      jasjamz
      Are you able to view power logger files? I wanted an opinion on a cars performance. im not sure if it has a backpressure issue, valvespring problem, or converter issue. 30 psi on pump gas and alky but looking for more.
    7. Ms. FastNasty
      Ms. FastNasty
      I'll be there...sportin some Ed Hardy! lmao ;)
    8. Ms. FastNasty
      Ms. FastNasty
      LOL...thought you had totally forgot... :p
    9. Ms. FastNasty
      Ms. FastNasty
      Um...we're already friends on FB...lol
    10. bison
      bison
      I'm ok. Heading up to LVD right now looking for 9's on a stock short block. I'll look for you on FB.
    11. Ms. FastNasty
      Ms. FastNasty
      Haven't talked to you in a hot second...how ya been?
    12. hungerbuhler1
      hungerbuhler1
      Bison this is what kdk is doing so far to my motor.83# injectors,high current injector harness,champion ported iron heads, champion ported intake,ast roller cam 210-210,precision plenum, 70mm tb & plate,rjc front mount ic,iac boss,razor meth injection,roller rockers 1.65, MAF hot wire kit, rjc pulley set, hr poly mounts, wideband O2 fuel correction.
      We dont know if motor is bored over or anything else inside yet. Right now it ran 12's at 3/4 throttle cause my smc kit wasnt working and didnt want to hurt anything.Basically everything is coming off exept the precision 45a turbo [66mm] it has bmr front and rear suspension and hooks fine. If you can think of anything else too do please say so im up for anything. I saw your #'s earlier in the month and very impressed. You know what your doing i dont. Thanks for even offering to help. Thanks again,Jason
    13. RYAN GRAVES
      RYAN GRAVES
      Hey Bison, check craigslist in Flint, Michigan for G/N repairman. Just curious if this is the guy you were having problems with? Just giving you a heads up.
    14. vl1500
      vl1500
      Bison, I am rebuilding my motor using the stock pistons with studs and ARP rod bolts.My plan is for a daily driver but it will see some track time,I would like to rua low 11's but not sure on which head gasket to use,on my past rebuilds I used the stock GM head gaskets.Any help would be greatful.Thanks....
    15. xsbc63x
      xsbc63x
      you were right, i changed the filter for piece of mind (was the wrong one anyways, and drove it around for a little bit and it went to 30 hot in gear, it was only at 70-80 cold not 90. thanks for the piece of mind! Dave
    16. xsbc63x
      xsbc63x
      hey bison, i just got my tta running about 2 weeks ago, and still getting little issues worked out. the car hasn't been driving on the street much (just around the neighborhood) . i just noticed today that the engine oil psi isn't dropping like it should/did last week. the car starts out at about 90psi and stays there. I'm running brad penn 30wt break in oil and the motor is fresh. I'm using the stock gauge on the dash and stock sender. last week it would start at 90 and then drop to about 40-50, but as of today letting it idle for 10-15 mins or so it stays at about 90 and doesn't drop. any ideas? oil filter possibly? Like I said it has been running for 2-3 weeks or so (maybe 3 miles on it) and it just started doing this now. Any help appreciated! Thanks,
      Dave
    17. GOT JCE
      GOT JCE
      CT Turbo Buick get together

      --------------------------------------------------------------------------------

      --------------------------------------------------------------------------------
      Oct 3rd at Pat's Auto care in East windsor CT at 1pm. All Turbo Buick powered cars are welcome as well as muscle and show cars. Cookout and refreshments along with giveaways and maybe a raffle of some sort. If we get a great turnout we will make this a yearly thing. If you are interested in possibly donating something (doesn't have to be buick related)please let me know. I will be donating something related to welding supplies and methanol. Mark from TRcustomparts will be offering something as always(thanks to a great guy and vendor)and Miguel is working on Jack Cotton for a giveaway item. Miguel of Pats Auto will be donating some sort of service(buffing/detail) pm me for questions,AJ
  • Loading...
  • Loading...
  • Signature

    TURBOCHARGER SALES AND SERVICE
    CYLINDER HEADS, CUSTOM CAMSHAFTS, VALVE SPRINGS, AND VALVETRAIN ACCESSORIES
    DYNO TUNING

    BPE2013@HOTMAIL.COM
    http://www.turbobuick.com/forums/th...00hp-57-59-61-62-63-64-66-67-70-72-76.403861/